Profile
Personal Photo

No Photo

Options
Custom Title
garnett doesn't have a custom title currently.
Personal Info
Location: No Information
Born: No Information
Website: No Information
Interests
No Information
Other Information
Gender:: Female
Test:: No Information
Statistics
Joined: 02/22/2016
Status: (Offline)
Last Seen: Jan 24 2018, 03:33 PM
Local Time: Feb 17 2018, 08:13 PM
18 posts (0 per day)
( 0.01% of total forum posts )
Contact Information
AIM No Information
Yahoo No Information
GTalk No Information
MSN No Information
SKYPE No Information
Unread Message Message: Click here
Unread Message Email: Private
Signature
View Signature

garnett

Members

Topics
Posts
Comments
Friends
Video
My Content
Aug 16 2017, 05:23 PM
BOARD LINK: http://amemoryaway.jcink.net

So I'm having a problem designing a new skin for my forum. I'm trying to find a way for the edit, report, quote, and delete macros to show up as a color entered from the custom profile fields (it's <!-- |field_15| --> to be precise). And I've run into several problems.

The skin in question is not viewable to guests. But you can login to my test account to see what's happening. Ignore the mess and weird colors - it's a work in progress.
Username: Test!Sage
Password: test

Option 1: In the Post Row HTML Template, I tried to make a CSS workaround by defining field 15 as the font color for that class (see code snippet below). But when I do that, it pulls the color from the profile of the last person that posted on that page and applies it to all the buttons (see attached image - the buttons in the yellow bar should have yellow text, the purple bar should have purple text, and the blue bar should have blue text. But they're all blue!!). Weird??

CODE
<div class="postback">
   <a name='entry<!-- |pid| -->'></a>
   <div class="posttop"  style="background-color: <!-- |field_15| -->;"><table width="100%" border-collapse="collapse"><tr>
       <td><div class="postimage"><object data="<!-- |field_13| -->" class="postimage2" type="image/jpg">
   <img class="postimage2" src="http://i.imgur.com/ju6lFDC.png" />
</object></div></td>
       <td width="100%"><a href="http://amemoryaway.jcink.net/index.php?showuser=<!-- |poster_id| -->"><div class="postname" style="color:#fff;"><!-- |author_name| --></div></a>

<div class="postbuttonbar"><a title="permalink" href="#" onclick="link_to_post(<!-- |pid| -->); return false;"><span class="postbtn"><i class="fa fa-link" aria-hidden="true"></i>  <span class="postbtntxt">permalink</span></span></a><a href="http://amemoryaway.jfbs.net/index.php?act=Msg&CODE=04&MID=<!-- |poster_id| -->"><span class="postbtn" title="private message"><i class="fa fa-paper-plane" aria-hidden="true"></i>
<span class="postbtntxt">pm</span></span></a> <!-- |mod_checkbox| --><span style="float: left; margin-left: 40px;"><span class="posted postbtn">Posted <!-- |post_date| --></span><!-- |edit_button| --><!-- |quote_button| --><!-- |report_link| --><!-- |delete_button| --></span></div></td>
   </tr></table></div>

   <table width="100%" border="0" cellspacing="0" cellpadding="0">
       <tr>
           <td valign="top" class="postcolumnleft">
               


               <div class="<!-- |post_css| -->" style="width: 100%;"><div id="pid_<!-- |pid| -->" style="width: 100%;"><!-- THE POST <!-- |pid| --> --><div class='postcolor'><!-- |post| --></div><!-- |attachments| --><!-- |signature| --><!-- THE POST --></div></div>
           </td>
           <td valign="top" class="postcolumnright">
                <center><div class="miniprof" style="width: 100%;"><!-- |mini_profile| --></div></center>
           </td>
       </tr>
   </table>

</div>
<div class="postbottom" style="background-color: <!-- |field_15| -->;"></div>


<style type="text/css">
   .postbtn { color: <!-- |field_15| --> !important; }
   .postbtn a:link, .postbtn a:visited, .postbtn a:active { color: <!-- |field_15| --> !important; }
   .postbtn2  {color: <!-- |field_15| --> !important; }
   .postbtn2 a:link, .postbtn2 a:visited, .postbtn2 a:active { color: <!-- |field_15| --> !important; }

   .textinput {width: 90%;}
</style>


I tried the above code with and without the !important indicators and there was no change.

Option 2: Just surround the button variables with <span style="color: <!-- |field_15| -->;"></span>! Except that does nothing. The text just stays the regular link color. This option does work for the post date, permalink, and PM buttons I have, but they're not being pulled from the macros.

Option 3: Put the color in the macro code itself! Same result as option 2.

I don't know that there are other options I can try, so that's why I'm here. Option 1 was the only one that gave me any kind of result, it just wasn't the one I was looking for. If there's something obvious I'm missing, or something small I completely overlooked, I'm sorry for the trouble. But I've been scratching my head for hours trying to figure out wtf is going on here.

If there's no solution, I can definitely use my backup plan. But any help at all would be appreciated!
Jun 24 2017, 07:20 PM
This is a minor annoyance more than anything and doesn't need immediate attention. But I've noticed at https://amemoryaway.jcink.net that when I post a thread and assign a post icon, if I edit that thread (both in quick edit and in full edit), the post icon disappears! I assume it's because the default is set to [Use None], so it reverts back to that setting when I go to edit a post. But it's very annoying to have to select the post icon every time I edit that opening post.

This mostly comes into play when I'm editing an announcement or signup sheet on my forum, or when members edit their writing prompts and other character development threads. So it's not a huge issue, just really annoying.

Does anyone know of a way to keep it from reverting to [Use None] during an edit? Or is this an annoyance I should learn to live with?
May 31 2017, 03:08 AM
I'm trying to get all my ducks in a row here and make my forum https:// ready, but I've run into a snag. When I run a security inspection in chrome, it pulls up a red flag for shop.png and affs.png. I found that they show up in this string of code:

CODE
<img src="style_images/1/atb_help.gif" border="0" alt="" />&nbsp;<a href='https://amemoryaway.jcink.net/index.php?act=Help'>Help</a>&nbsp; &nbsp;&nbsp;<img src="style_images/1/atb_search.gif" border="0" alt="" />&nbsp;<a href='https://amemoryaway.jcink.net/index.php?act=Search&amp;f='>Search</a>&nbsp; &nbsp;&nbsp;<img src="style_images/1/atb_members.gif" border="0" alt="" />&nbsp;<a href='https://amemoryaway.jcink.net/index.php?act=Members'>Members</a>&nbsp; &nbsp;&nbsp;<img src="style_images/1/atb_calendar.gif" border="0" alt="" />&nbsp;<a href='https://amemoryaway.jcink.net/index.php?act=calendar'>Calendar</a>&nbsp; &nbsp;&nbsp; <img src="http://ibservice.b1.jcink.com/style_images/1/shop.png" border="0" alt="" />&nbsp;<a href='?act=store'>Shop</a>&nbsp; &nbsp;&nbsp; <img src="http://ibservice.b1.jcink.com/style_images/1/affs.png" border="0" alt="" />&nbsp;<a href='?act=daffiliates'>Affiliates</a>&nbsp; &nbsp;&nbsp;<img src='style_images/1/atb_shoutbox.gif' border='0' />&nbsp;<a href='https://amemoryaway.jcink.net/index.php?&act=Shoutbox'>Shoutbox</a>


Now, I can't find this in the stylesheet or the board wrappers (or webpages or html templates) and I think I've run out of places to look to pull those images and replace them. Can anyone point me in the right direction?

You can find my board at amemoryaway.jfbs.net
Mar 29 2017, 11:00 AM
Not sure if this is the right place or not, but I was wondering if there was a way to order my affiliates? I'm not able to edit the affiliate number and don't want to go through and delete/re-add existing ones. Not a big issue, just my need of things to look and be ordered how I want them to >.<
Feb 15 2017, 01:27 PM
PM table widths [SOLVED]
This is similar to my problem here: http://jcink.net/index.php?showtopic=27015, but I thought i should open a new topic since that was solved and I noticed this quite a bit later.

When I view a private message, the table cells are not the correct widths (see picture). There may just be something I missed, but any help would be appreciated.

Site link: http://amemoryaway.jfbs.net
Last Visitors


Aug 16 2017, 08:49 PM




Jun 24 2017, 11:27 PM



Comments
No comments posted.
Add Comment